
  
 
  
 
  

AN0400 
Ameba-D Application Note 

 

 

 

Realtek Semiconductor Corp. 

No. 2, Innovation Road II, Hsinchu Science Park, Hsinchu 300, Taiwan 

Tel.: +886-3-578-0211. Fax: +886-3-577-6047 

www.realtek.com 

Rev. 9.0 

Apr., 2024 



 Ameba-D 

Application Note All information provided in this document is subject to legal disclaimers. © REALTEK 2021. All rights reserved. 

2 

COPYRIGHT 

© 2021 Realtek Semiconductor Corp. All rights reserved. No part of this document may be reproduced, transmitted, transcribed, stored in a 
retrieval system, or translated into any language in any form or by any means without the written permission of Realtek Semiconductor Corp. 

DISCLAIMER 

Please Read Carefully: 

Realtek Semiconductor Corp., (Realtek) reserves the right to make corrections, enhancements, improvements and other changes to its 
products and services. Buyers should obtain the latest relevant information before placing orders and should verify that such information is 
current and complete. 

Reproduction of significant portions in Realtek data sheets is permissible only if reproduction is without alteration and is accompanied by all 
associated warranties, conditions, limitations, and notices. Realtek is not responsible or liable for such reproduced documentation. Information 
of third parties may be subject to additional restrictions.  

Buyers and others who are developing systems that incorporate Realtek ǇǊƻŘǳŎǘǎ όŎƻƭƭŜŎǘƛǾŜƭȅΣ άCustomersέύ ǳƴŘŜǊǎǘŀƴŘ ŀƴŘ ŀƎǊŜŜ ǘƘŀǘ 
Customers remain responsible for using their independent analysis, evaluation and judgment in designing their applications and that 
Customers have full and exclusive responsibility to assure the safety of Customers' applications and compliance of their applications (and of all 
Realtek products used in or for CustomersΩ ŀǇǇƭƛŎŀǘƛƻƴǎύ ǿƛǘƘ ŀƭƭ ŀǇǇƭƛŎŀōƭŜ ǊŜƎǳƭŀǘƛƻƴǎΣ ƭŀǿǎ ŀƴŘ ƻǘƘŜǊ ŀǇǇƭƛŎŀōƭŜ ǊŜǉǳƛǊŜƳŜƴǘǎΦ 5ŜǎƛƎƴŜǊ 
represents that, with respect to their applications, Customer has all the necessary expertise to create and implement safeguards that (1) 
anticipate dangerous consequences of failures, (2) monitor failures and their consequences, and (3) lessen the likelihood of failures that might 
cause harm and take appropriate actions. Customer agrees that prior to using or distributing any applications that include Realtek products, 
Customer will thoroughly test such applications and the functionality of such Realtek products as used in such applications. 

RealtekΩs provision of technical, application or other design advice, quality characterization, reliability data or other services or information, 
including, but not limited to, reference designs and materials relating to evaluation kitsΣ όŎƻƭƭŜŎǘƛǾŜƭȅΣ άwŜǎƻǳǊŎŜǎέύ ŀǊŜ ƛƴǘŜƴŘŜŘ ǘƻ assist 
designers who are developing applications that incorporate Realtek products; by downloading, accessing or using wŜŀƭǘŜƪΩs Resources in any 
way, Customer (individually or, if Customer is acting on behalf of a company, CustomerΩs company) agrees to use any particular Realtek 
Resources solely for this purpose and subject to the terms of this Notice.  

RealtekΩs provision of Realtek Resources does not expand or otherwise alter RealtekΩs applicable published warranties or warranty disclaimers 
for RealtekΩs products, and no additional obligations or liabilities arise from Realtek providing such Realtek Resources. Realtek reserves the 
right to make corrections, enhancements, improvements and other changes to its Realtek Resources. Realtek has not conducted any testing 
other than that specifically described in the published documentation for a particular Realtek Resource. 

Customer is authorized to use, copy and modify any individual Realtek Resource only in connection with the development of applications that 
include the Realtek product(s) identified in such Realtek Resource. No other license, express or implied, by estoppel or otherwise to any other 
Realtek intellectual property right, and no license to any technology or intellectual property right of Realtek or any third party is granted 
herein, including but not limited to any patent right, copyright, mask work right, or other intellectual property right relating to any 
combination, machine, or process in which Realtek products or services are used. Information regarding or referencing third-party products or 
services does not constitute a license to use such products or services, or a warranty or endorsement thereof. Use of Realtek Resources may 
require a license from a third party under the patents or other intellectual property of the third party, or a license from Realtek under the 
patents or other RealtekΩs intellectual property. 

RealtekΩs Resources are provided άas isέ and with all faults. Realtek disclaims all other warranties or representations, express or implied, 
regarding resources or use thereof, including but not limited to accuracy or completeness, title, any epidemic failure warranty and any implied 
warranties of merchantability, fitness for a particular purpose, and non-infringement of any third party intellectual property rights.   

Realtek shall not be liable for and shall not defend or indemnify Customer against any claim, including but not limited to any infringement claim 
that related to or is based on any combination of products even if described in Realtek Resources or otherwise. In no event shall Realtek be 
liable for any actual, direct, special, collateral, indirect, punitive, incidental, consequential or exemplary damages in connection with or arising 
out of RealtekΩs Resources or use thereof, and regardless of whether Realtek has been advised of the possibility of such damages. Realtek is not 
responsible for any failure to meet such industry standard requirements. 

Where Realtek specifically promotes products as facilitating functional safety or as compliant with industry functional safety standards, such 
products are intended to help enable customers to design and create their own applications that meet applicable functional safety standards 
and requirements. Using products in an application does not by itself establish any safety features in the application. Customers must ensure 
compliance with safety-related requirements and standards applicable to their applications. Designer may not use any Realtek products in life-
critical medical equipment unless authorized officers of the parties have executed a special contract specifically governing such use. Life-critical 
medical equipment is medical equipment where failure of such equipment would cause serious bodily injury or death. Such equipment 
includes, without limitation, all medical devices identified by the U.S.FDA as Class III devices and equivalent classifications outside the U.S. 
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Customers agree that it has the necessary expertise to select the product with the appropriate qualification designation for their applications 
and that proper product selection is at CustomersΩ own risk. Customers are solely responsible for compliance with all legal and regulatory 
requirements in connection with such selection. 

Customer will fully indemnify Realtek and its representatives against any damages, costs, losses, ŀƴŘκƻǊ ƭƛŀōƛƭƛǘƛŜǎ ŀǊƛǎƛƴƎ ƻǳǘ ƻŦ 5ŜǎƛƎƴŜǊΩǎ ƴƻƴ-
compliance with the terms and provisions of this Notice. 

TRADEMARKS 

Realtek is a trademark of Realtek Semiconductor Corporation. Other names mentioned in this document are trademarks/registered trademarks 
of their respective owners. 

USING THIS DOCUMENT 
Though every effort has been made to ensure that this document is current and accurate, more information may have become available 
subsequent to the production of this guide.
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Convention 

Note for Parameters  

All device parameter data in this document are valid over the device silicon fabrication process window, the device operating voltage range, 
and the device operating temperature range (-25°C to +85°C). 

Abbreviations for MCU 

Ameba-D consists of two MCUs:  
 ̧ Real-M300: a high performance MCU (Armv8-M, Cortex-M33 instruction set compatible) called KM4 thereafter  
 ̧ Real-M200: a low power MCU (Armv8-M, Cortex-M23 instruction set compatible) called KM0 thereafter  
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1 Building Environment 

1.1 Introduction 

This chapter illustrates how to build Realtek Wi-Fi SDK under GCC environment. It focuses on both Windows platform and Linux distribution. 
The build and download procedure are quite similar between Windows and Linux operating system. 

 ̧ For Windows, Windows 7 64-bit is used as platform. 
 ̧ For Linux distribution, Ubuntu 18.04 64-bit is used as platform.  

1.2 Preparing GCC Environment 

1.2.1 Windows 

On Windows, you can use Cygwin as the GCC environment. Cygwin is a large collection of GNU and open source tools which provide 
functionality similar to a Linux distribution on Windows.  
 
Click http://cygwin.com and download the Cygwin packageҍsetup-x86.exe for your Windows platform. 
 
Note:  

 ̧ Only 32-bit Cygwin is supported both for 32-bit Windows and 64-bit Windows. 
 ̧ 5ǳǊƛƴƎ ǘƘŜ ƛƴǎǘŀƭƭŀǘƛƻƴ ƻŦ /ȅƎǿƛƴ ǇŀŎƪŀƎŜΣ ƛƴŎƭǳŘŜ Ψ5ŜǾŜƭ -Ҕ ƳŀƪŜΩ ŀƴŘ ΨaŀǘƘ -Ҕ ōŎΩ ǳǘƛƭƛǘƛŜǎ ƻƴ ǘƘŜ Select Packages step, as Fig 1-1 and Fig 

1-2 shows. 
 

 

Fig 1-1 ΨDevelΩ setting during Cygwin installation 
 

http://cygwin.com/
http://www.cygwin.com/setup-x86.exe
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Fig 1-2 ΨMathΩ setting during Cygwin installation 

1.2.2 Linux 

On Linux, some packages must be installed for the GCC environment. 
 ̧ libc6-i386 (GNU C library for 64-bit platform. If you are using 32-bit platform, install libc6 instead) 
 ̧ lib32ncurses5-dev (32-bit terminal handling for 64-bit platform. If you are using 32-bit platform, install libncurses5-dev instead) 
 ̧ make 
 ̧ bc 
 ̧ gawk 
 ̧ ncurses 

Some of these packages may have been pre-installed in your operating system. Use package manager to check and decide whether to install. 
For the last three packages, you can also type the corresponding version command on terminal like the following figures to check whether it 
exists. If not, make these packages installed. 
 

 ̧ $ make ςv 
If make ƛǎƴΩǘ ƛƴǎǘŀƭƭŜŘΣ ǘȅǇŜ apt-get install make to install make. 

 
 

 ̧ $ bc ςv 
If bc ƛǎƴΩǘ ƛƴǎǘŀƭƭŜŘΣ ǘȅǇŜ apt-get install bc to install bc. 

 
 

 ̧ $ gawk --v 
If gawk ƛǎƴΩǘ ƛƴǎǘŀƭƭŜŘΣ ǘȅǇŜ apt-get install gawk to install gawk. 
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 ̧ ncurses  
ncurses is needed if you want to use make menuconfig command. Type apt-get install ncurses-dev to install ncurses. 

1.3 Building Code 

This section illustrates how to build SDK. First, you need to switch to GCC project directory. 
 ̧ For Windows, open Cygwin terminal and use $ cd command to change directory to KM0 or KM4 project directory of Ameba-D SDK. 

Note: You need to replace the {path} to your own SDK location, and ŀŘŘ άŎȅƎŘǊƛǾŜέ ǇǊŜŦƛȄ ƛƴ ŦǊƻƴǘ ƻŦ ǘƘŜ {5Y ƭƻŎŀǘƛƻƴ, so that Cygwin can 
access your file system. 
Â $ cd /cygdrive/{path}/project/ realtek_amebaD_va0_example/GCC-RELEASE/project_lp 
Â $ cd /cygdrive/{path}/project/ realtek_amebaD_va0_example/GCC-RELEASE/project_hp 

 ̧ For Linux, open its own terminal and use $ cd command to change directory to KM0 or KM4 project directory of Ameba-D SDK. 
Â $ cd /{path}/project/ realtek_amebaD_va0_example/GCC-RELEASE/project_lp 
Â $ cd /{path}/project/ realtek_amebaD_va0_example/GCC-RELEASE/project_hp 

1.3.1 Normal Image 

To build SDK for normal image, simply use $ make all command under the corresponding project directories on Cygwin (Windows) or terminal 
(Linux). 

1.3.1.1 KM0 Project 

For KM0 project, if the terminal contains άkm0_image2_all.binέ and άLƳŀƎŜ ƳŀƴƛǇǳƭŀǘƛƴƎ endέ ƻǳǘǇǳǘ ƳŜǎǎŀƎŜΣ it means that the image has 
been built successfully, as Fig 1-3 shows.  
 

 

Fig 1-3 KM0 project make all 
 
If somehow it is built failed, type $ make clean to clean and then redo the make procedure. After successfully built, the image file is located in 
project/realtek_amebaD_va0_example/GCC-RELEASE/project_lp/asdk/ image, as Fig 1-4 shows. 
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Fig 1-4 KM0 project bin generation 

1.3.1.2 KM4 Project 

For KM4 project, if the terminal contains άkm4_image2_all.binέ and άLƳŀƎŜ ƳŀƴƛǇǳƭŀǘƛƴƎ endέ ƻǳǘǇǳǘ ƳŜǎǎŀƎŜΣ it means that the image has 
been built successfully, as Fig 1-5 shows. 

 

Fig 1-5 KM4 project make all 
 
If somehow it built failed, type $ make clean to clean and then redo the make procedure. After built successfully, the image file is located in 
project/ realtek_amebaD_va0_example/ GCC-RELEASE/project_hp/asdk/ image, as Fig 1-6 shows. 

 

Fig 1-6 KM4 project bin generation 
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1.3.2 MP Image 

Use make mp command under / project/ realtek_amebaD_va0_example/ GCC-RELEASE/project_hp to generate MP image. After successful 
compilation, you will find the generated images under /project/ realtek_amebaD_va0_example/ GCC-RELEASE/project_hp/asdk/image, as 
shown in Fig 1-7.  
 

 

Fig 1-7 MP image generation 

1.4 Setting Debugger 

This section illustrates how to enter GDB debugger mode. 
 
Note: Considering KM4 is powered-on by KM0, make sure that KM0 has boot up already before accessing KM4 by J-Link or Probe. Clicking 
Reset button on demo board is a recommended way to boot up KM0. 

1.4.1 Probe 

1.4.1.1 Windows 

Ameba-D Device Board supports Probe debugger. We can use Probe to download the software and enter GBD debugger mode under GCC 
environment. Refer to Fig 1-8 to connect Probe debugger to the SWD of Ameba-D.  
(1) Install Probe driver 

Before using the Probe, its driver is required to be installed. Obtain the RLX_Probe_Driver_2.3.11p22_Setup.exe under tools/probe, then 
install it correctly. Refer to Fig 1-8 to connect Probe debugger to the SWD of Ameba-D, which is connecting TCK pin of Probe to SWD CLK 
pin of Ameba-D, and TMS pin of Probe to SWD DATA pin of Ameba-D. WhatΩs more, a common ground is needed between Probe Board 
and Ameba-D Device Board. 
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1 3 5 7 9 11 13

2 4 6 8 10 12 14
TCK JRST

DATA CLK

GND 1833

Probe Ameba-D SWD

TMSTDOTDITRSI

 

Fig 1-8 Wiring diagram of connecting Probe to SWD 
 
(2) Execute the cm0_RTL_Probe.bat 

After the installation of the software pack, execute the cm0_RTL_Probe.bat under / project/ realtek_amebaD_va0_example/ GCC-
RELEASE/ project_lp/ jlink_script. 
Note: The default path of Probe driver in cm0_RTL_Probe.bat file is C:\ RLX\ PROBE\ rlx_probe_driver.exe, you may have to change the 
path according to your own settings. 

 
The started Probe server looks like Fig 1-9. This window should NOT be closed if you want to download the image or enter debug mode. 

 

 

Fig 1-9 KM0 Probe server connection under Windows 
 
(3) Setup Probe for KM0 

On the Cygwin terminal, type $ make setup GDB_SERVER=probe command to select Probe debugger, as Fig 1-10 shows. 
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Fig 1-10 KM0 Probe setup under Windows 
 
(4) Execute the cm4_RTL_Probe.bat 

Execute the cm4_RTL_Probe.bat under / project/ realtek_amebaD_va0_example/ GCC-RELEASE/ project_hp/ jlink_script the same as 
executing the cm0_RTL_Probe.bat. The started Probe server looks like Fig 1-11. This window should NOT be closed if you want to enter 
debug mode. 

 

Fig 1-11 KM4 Probe server connection under Windows 
 

Note: When cm4_RTL_Probe.bat is running, the connection built by running cm0_RTL_Probe.bat will be closed. If you want to connect 
the Probe to KM0 and KM4 simultaneously, follow the steps below: 
a) Make a copy of rlx_probe0.cfg under the folder /project / realtek_amebaD_va0_example/ GCC-RELEASE/project_hp/jlink_script 

and rename it as rlx_probe1.cfg. 
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b) Cut rlx_probe1.cfg and move it to /project / realtek_amebaD_va0_example/ GCC-RELEASE/project_lp/jlink_script. 
c) Connect the Probe to both KM0 and KM4 by executing cm0_RTL_Probe.bat under /project / realtek_amebaD_va0_example/ GCC-

RELEASE/project_lp/jlink_script. 
 
(5) Setup Probe for KM4 

On the Cygwin terminal, type $ make setup GDB_SERVER=probe command to select Probe debugger, as Fig 1-12 shows. 
 

 

Fig 1-12 KM4 Probe setup under Windows 

1.4.1.2 Linux 

Before using Probe, its driver is required to be installed. Obtain the RLX_Probe_Linux_Driver_v2.3.11p22 under tools/probe and install it 
correctly. Then connect TCK pin of Probe to SWD CLK pin, and TMS pin of Probe to SWD DATA pin. WhatΩs more, a common ground is needed 
between Probe Board and Ameba-D Device Board. 
 
After the installation of the software pack, use ln ςs command in both folder / project/ realtek_amebaD_va0_example/ GCC-
RELEASE/ project_lp/ jlink_script and / project/ realtek_amebaD_va0_example/ GCC-RELEASE/ project_hp/ jlink_script to create a soft link to 
link the rlx_probe_driver.elf. 
 

   

Fig 1-13 Creating soft link to elf 
 
Open a new terminal under the corresponding project folder and type the following command to start probe server. This terminal should NOT 
be closed if you want to download the image or enter debug mode. 
 

 ̧ KM0 project 
For KM0, open a new terminal under/ project/ realtek_amebaD_va0_example/ GCC-RELEASE/ project_lp/ jlink_script, and type $ 
sudo ./rlx_probe_driver.elf. If connection is successful, the log is shown as Fig 1-14. 
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Fig 1-14 KM0 probe GDB server connection success under Linux 
 
Open a new terminal under the same project folder (/ project/ realtek_amebaD_va0_example/ GCC-RELEASE/ project_lp), type $ make setup 
GDB_SERVER=probe command to select Probe debugger. 
 

 ̧ KM4 project 
For KM4, open a new terminal under / project/ realtek_amebaD_va0_example/ GCC-RELEASE/ project_hp/ jlink_script, and type $ 
sudo./rlx_probe_driver.elf. If connection is successful, the log is shown as Fig 1-15. 
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Fig 1-15 KM4 probe GDB server connection success under Linux 
 
Open a new terminal under the same project folder (/ project/ realtek_amebaD_va0_example/ GCC-RELEASE/ project_hp), type $ make setup 
GDB_SERVER=probe command to select Probe debugger. 

1.4.2 J-Link 

Ameba-D also supports J-Link debugger. You need to do some hardware configuration to use J-Link debugger. Refer to Fig 1-16 to connect J-
Link to the SWD of Ameba-D, which is connecting SWCLK pin of J-Link to SWD CLK pin of Ameba-D, and SWDIO pin of J-Link to SWD DATA pin of 
Ameba-D. After finishing these configurations, connect it to PC. 
 

13 11 9 7 5 3 1

14 12 10 8 6 4 2
GND GND

DATA CLK

GND 1833

J-Link Ameba-D SWD

GNDGNDGNDGND
20 18 16

GNDGNDGND VCC
(optional)

VCCN/UN/UN/U SWDIOSWCLKSWO
19 17 15

N/CN/C RESET

 

Fig 1-16 Wiring diagram of connecting J-Link to SWD 
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Note: For Ameba-D CPU, the J-Link version must be v9 or higher. If Virtual Machine (VM) is used as your platform, make sure the USB 
connection setting between VM host and client is correct, so that the VM host can detect the device. 

1.4.2.1 Windows 

(1) Install J-Link GDB server 
Besides the hardware configuration, J-Link GDB server is also required to install. For Windows, click 
https://www.segger.com/downloads/jlink and download the software in άJ-Link Software and Documentation Packέ, then install it 
correctly. 
Note: The version of J-Link GDB server displayed in the pictures below is just an example, you can select the latest version to download. 

 
(2) Execute the cm0_jlink.bat 

After the installation of the software pack, execute the cm0_jlink.bat under 
/project/ realtek_amebaD_va0_example/ GCCRELEASE/project_lp/ jlink_script. 
Note: The default path of J-Link driver in cm0_jlink.bat file is C:\ Program Files (x86)\ SEGGER\ JLink_V634b\ JLinkGDBServer.exe, you may 
have to change the path according to your own settings. 

 
The started J-Link GDB server looks like Fig 1-17. This window should NOT be closed if you want to download the image or enter debug 
mode. 

 

 

Fig 1-17 KM0 J-Link GDB server connection under Windows 
 
(3) Setup J-Link for KM0 

On the Cygwin terminal, type $ make setup GDB_SERVER=jlink command before to select J-Link debugger, as Fig 1-18 shows. 
 

 

https://www.segger.com/downloads/jlink
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Fig 1-18 KM0 J-Link setup under Windows 
 
(4) Execute the cm4_jlink.bat 

Execute the cm4_jlink.bat under /project/ realtek_amebaD_va0_example/ GCCRELEASE/project_hp/ jlink_script the same as executing 
the cm0_jlink.bat. The started J-Link GDB server looks like Fig 1-19. This window should NOT be closed if you want to download the 
image or enter debug mode. 

 

  

Fig 1-19 KM4 J-Link GDB server connection under Windows 
 
(5) Setup J-Link for KM4 

On the Cygwin terminal, type $ make setup GDB_SERVER=jlink command to select J-Link debugger, as Fig 1-20 shows. 
 

 

Fig 1-20 KM4 J-Link setup under Windows 

1.4.2.2 Linux 

For J-Link GDB server, click https:// www.segger.com/downloads/jlink and download the software in άW-Link Software and Documentation 
PackέΦ ²Ŝ ǎǳƎƎŜǎǘ ǳǎƛƴƎ 5Ŝōƛŀƴ ǇŀŎƪŀƎŜ ƳŀƴŀƎŜǊ ǘƻ ƛƴǎǘŀƭƭ ǘƘŜ 5Ŝōƛŀƴ ǾŜǊǎƛƻƴ. 

 ̧ $ dpkg ςi jlink_6.0.7_x86_64.deb 
 
After the installation of the software pack, there is ŀ ǘƻƻƭ ƴŀƳŜŘ άW[ƛƴƪD5.{ŜǊǾŜǊέ ǳƴŘŜǊ W[ƛƴƪ ŘƛǊŜŎǘƻǊȅΦ ¢ŀƪŜ ¦ōǳƴǘǳ м8.04 as an example, the 
JLinkGDBServer can be found at /opt/SEGGER/JLink. Open a new terminal under the corresponding project folder and type the following 
command to start GDB server. This terminal should NOT be closed if you want to download the iamge or enter debug mode. 

https://www.segger.com/downloads/jlink
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1.4.2.2.1 KM0 Project 

For KM0, open a new terminal under / project/ realtek_amebaD_va0_example/ GCC-RELEASE/ project_lp/ jlink_script, and type $ 
/opt/SEGGER/JLink/JLinkGDBServer ςdevice cortex-m23 -if SWD -scriptfile AP1_KM0.JLinkScript -port 2331, as Fig 1-21 shows. If connection 
is successful, the log is shown as Fig 1-22. 
 

 

Fig 1-21 KM0 J-Link GDB server connection setting under Linux 
 

 

Fig 1-22 KM0 J-Link GDB server connection success under Linux 
 
Open a new terminal under the same project folder, type $ make setup GDB_SERVER=jlink command to select J-Link debugger, as Fig 1-23 
shows. 
 

 

Fig 1-23 KM0 J-Link terminal setup under Linux 
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1.4.2.2.2 KM4 Project 

For KM4, open a new terminal under / project/ realtek_amebaD_va0_example/ GCC-RELEASE/ project_hp/ jlink_script, and type $ 
/opt/SEGGER/JLink/JLinkGDBServer ςdevice cortex-m33 -if SWD -scriptfile AP2_KM4.JLinkScript ςport 2335, as Fig 1-24 shows. If connection 

is successful, the log is shown as Fig 1-25.  

 

 

Fig 1-24 KM4 J-Link GDB server connection setting under Linux 
 

 

Fig 1-25 KM4 J-Link GDB server connection success under Linux 
 
Open a new terminal under the same project folder, type $ make setup GDB_SERVER=jlink command to select J-Link debugger, as Fig 1-26 
shows. 
 

 

Fig 1-26 KM4 J-Link terminal setup under Linux 
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1.5 Downloading Image to Flash 

This section illustrates how to download image to Flash. 
 
To download software into Ameba-D Device Board, make sure steps mentioned in section 1.3 to 1.4 are done and then type $ make flash 
command on Cygwin (Windows) or terminal (Linux). 

 
Make sure that the J-Link GDB connection is established with -device cortex-m23 and -port 2331 before executing $make flash. 

 
Both KM0 and KM4 download codes by this command. This command downloads the software into Flash and it will take several seconds to 
finish, as shown in Fig 1-27. 
 

 
 

  

Fig 1-27 Download codes success log 
 

After downloaded successfully, press the Reset button and you can see the device is booted with new imageȂ 

 

 
Â For new device board or device board with erased all images, program both KM0 and KM4 by commands $ make flash in order. That 

is, type $ make flash in project_lp first, then change the path to project_hp and type $ make flash. After downloading both images 
successfully, press the Reset ōǳǘǘƻƴΦ hǘƘŜǊǿƛǎŜΣ άCƭŀǎƘ bƻǘ ǇǊƻƎǊŀƳƳŜŘέ ǿƛƭƭ ōŜ ǎƘƻǿƴΦ 

Â For Probe downloading, 
É Make chip enter download mode before downloading code to Flash 
É Download KM4 project code also through cm0_RTL_Probe.bat 
É Probe uses USB 1.0 interface, so its download rate is limited by the USB 1.0 protocol. 

1.6 Entering Debug Mode 

To enter GDB debugger mode, make sure steps mentioned in section 1.3 to 1.5 are finished and then reset the device first. After resetting the 
chip, type $ make debug command on Cygwin (Windows) or terminal (Linux). 

 ̧ For Windows, a popup window will display, as shown in Fig 1-28. 
 ̧ For Linux, the log is shown in Fig 1-29. 
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Fig 1-28 Debug window under Windows 
 

 

Fig 1-29 Debug window under Linux 

1.7 Command List 

The commands used above are listed in Table 1-1. 

Table 1-1 Command list 

Usage Command Description 

all $ make all Compile project to generate ram_all.bin 

setup $ make setup GDB_SERVER= jlink Select GDB_SERVER 

flash $ make flash Download ram_all.bin to Flash 

clean $ make clean Remove compile file όϝΦōƛƴΣ ϝΦƻΣ Χύ 

clean_all $ make clean_all Remove compile result and toolchains 

debug $ make debug Enter debug mode 
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1.8 GDB Debugger Basic Usage 

GDB, the GNU project debugger, allows you to examine the program while it executes, and it is helpful for catching bugs. Section 1.6 has 
described how to enter GDB debugger mode, this section illustrates some basic usage of GDB commands. For further information about GDB 
debugger and its commands, click https://www.gnu.org/software/gdb/ and https://sourceware.org/gdb/current/onlinedocs/gdb/. 

Table 1-2 GDB debugger command list 

Usage Command Description 

Breakpoint $ break Breakpoints are set with the break command (abbreviated b). 
The usage can be found at https://sourceware.org/gdb/current/onlinedocs/gdb/Set-Breaks.html 

Watchpoint $ watch You can use a watchpoint to stop execution whenever the value of an expression changes. The related 
commands include watch, rwatch, and awatch. 
The usage of these commands can be found at https://sourceware.org/gdb/current/onlinedocs/gdb/Set-
Watchpoints.html 
Note: Keep the range of watchpoints less than 20 bytes. 

Print breakpoints 
& watchpoints 

$ info To print a table of all breakpoints, watchpoints set and not deleted, use the info command. You can 
simply type info to know its usage. 

Delete 
breakpoints 

$ delete To eliminate the breakpoints, use the delete command (abbreviated d). 
The usage can be found at https://sourceware.org/gdb/current/onlinedocs/gdb/Delete-Breaks.html. 

Continue $ continue To resume program execution, use the continue command (abbreviated c). 
The usage can be found at https://sourceware.org/gdb/current/onlinedocs/gdb/Continuing-and-
Stepping.html. 

Step $ step To step into a function call, use the step command (abbreviated s). It will continue running your program 
until control reaches a different source line. 
The usage can be found at https://sourceware.org/gdb/current/onlinedocs/gdb/Continuing-and-
Stepping.html. 

Next $ next To step through the program, use the next command (abbreviated n). The execution will stop when 
control reaches a different line of code at the original stack level. 
The usage can be found at https://sourceware.org/gdb/current/onlinedocs/gdb/Continuing-and-
Stepping.html. 

Quit $ quit To exit GDB debugger, use the quit command (abbreviated q), or type an end-of-file character (usually 
Ctrl-d). The usage can be found at https://sourceware.org/gdb/current/onlinedocs/gdb/Quitting-
GDB.html. 

Backtrace $ 
backtrace 

A backtrace is a summary of how your program got where it is. You can use backtrace command 
(abbreviated bt) to print a backtrace of the entire stack. 
The usage can be found at https://sourceware.org/gdb/current/onlinedocs/gdb/Backtrace.html. 

Print source lines $ list To print lines from a source file, use the list command (abbreviated l). 
The usage can be found at https://sourceware.org/gdb/current/onlinedocs/gdb/List.html. 

Examine data $ print To examine data in your program, you can use print command (abbreviated p). It evaluates and prints the 
value of an expression. 
The usage can be found at https://sourceware.org/gdb/current/onlinedocs/gdb/Data.html. 

1.9 Q & A 

1.9.1 ά9ǊǊƻǊ мнтέ ŦƻǊ .ǳƛƭŘƛƴƎ /ƻŘŜ 

If you use $ make all ŎƻƳƳŀƴŘ ǘƻ ōǳƛƭŘ ŎƻŘŜ ōǳǘ ŜƴŎƻǳƴǘŜǊ ά9ǊǊƻǊ мнтέ ŜǊǊƻǊ ƳŜǎǎŀƎŜ ƭƛƪŜ Fig 1-30Σ ƛǘΩǎ ŎŀǳǎŜŘ ōȅ ƛƴŎƻǊǊŜŎǘ /ȅƎǿƛƴ ǇŀŎƪŀƎŜΦ 
Both 32-bit and 64-bit operating system need to install 32-ōƛǘ ƛƴǎǘŀƭƭŀǘƛƻƴ /ȅƎǿƛƴ tŀŎƪŀƎŜ ҍ setup-x86.exe. 

 

https://www.gnu.org/software/gdb/
https://sourceware.org/gdb/current/onlinedocs/gdb/
https://sourceware.org/gdb/current/onlinedocs/gdb/Set-Breaks.html
https://sourceware.org/gdb/current/onlinedocs/gdb/Set-Watchpoints.html
https://sourceware.org/gdb/current/onlinedocs/gdb/Set-Watchpoints.html
https://sourceware.org/gdb/current/onlinedocs/gdb/Delete-Breaks.html
https://sourceware.org/gdb/current/onlinedocs/gdb/Continuing-and-Stepping.html
https://sourceware.org/gdb/current/onlinedocs/gdb/Continuing-and-Stepping.html
https://sourceware.org/gdb/current/onlinedocs/gdb/Continuing-and-Stepping.html
https://sourceware.org/gdb/current/onlinedocs/gdb/Continuing-and-Stepping.html
https://sourceware.org/gdb/current/onlinedocs/gdb/Continuing-and-Stepping.html
https://sourceware.org/gdb/current/onlinedocs/gdb/Continuing-and-Stepping.html
https://sourceware.org/gdb/current/onlinedocs/gdb/Quitting-GDB.html
https://sourceware.org/gdb/current/onlinedocs/gdb/Quitting-GDB.html
https://sourceware.org/gdb/current/onlinedocs/gdb/Backtrace.html
https://sourceware.org/gdb/current/onlinedocs/gdb/List.html
https://sourceware.org/gdb/current/onlinedocs/gdb/Data.html
http://www.cygwin.com/setup-x86.exe
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Fig 1-30 ά9rror 127έ ŜǊǊƻǊ ƳŜǎǎŀƎŜ 

1.9.2 άtŜǊƳƛǎǎƛƻƴ ŘŜƴƛŜŘέ 9ǊǊƻǊ ǳƴŘŜǊ [ƛƴǳȄ 

If you use $ make all command to cƻƳǇƛƭŜ ǇǊƻƧŜŎǘ ōǳǘ ŜƴŎƻǳƴǘŜǊ άPermission deniedέ ŜǊǊƻǊ ƳŜǎǎŀƎŜ like Fig 1-31, itΩs caused by file access 
permission. You can enter chmod -R 777 $SDK_FILENAME under the path of SDK first to change the permission of files in SDK, and then 
continue compile operation. 

 

 

Fig 1-31 άtŜǊƳƛǎǎƛƻƴ ŘŜƴƛŜŘέ ŜǊǊƻǊ ƳŜǎǎŀƎŜ under Linux 

1.9.3 How to Reset KM0/KM4 under Debug Mode? 

Steps to reset KM0 and KM4 are different. 
 ̧ CƻǊ YaлΣ ȅƻǳ ƴŜŜŘ ǘƻ ǳǎŜ ǘƘŜ άƳƻƴƛǘƻǊ ǊŜǎŜǘέ ƛƴǎǘǊǳŎǘƛƻƴ ƛƴ ŎƻǊǊŜǎǇƻƴŘƛƴƎ ǊǘƭψƎŘōψŘŜōǳƎΦǘȄǘ ǘƻ ǊŜǎŜǘ ƛǘ ǳƴŘŜǊ ŘŜōǳƎΦ ¢ƘŜ ŘŜŦŀult path of 

this file is under \project\ realtek_amebaD_va0_example\GCC-RELEASE\project_lp\asdk\gnu_utility\gnu_script\ rtl_gdb_debug.txt. Please 

ŎƘŀƴƎŜ ǘƘŜ ŘŜŦŀǳƭǘ ǎŜǘǘƛƴƎ ǿƘƛŎƘ ƛǎ άІƳƻƴƛǘƻǊ ǊŜǎŜǘ мέ ǘƻ άƳƻƴƛǘƻǊ ǊŜǎŜǘέ.  
 ̧  CƻǊ YaпΣ ȅƻǳ ƴŜŜŘ ǘƻ ǳǎŜ ǘƘŜ άƳƻƴƛǘƻǊ ǊŜǎŜǘέ ƛƴǎǘǊǳŎǘƛƻƴ ƛƴ ŎƻǊǊŜǎǇƻƴŘƛƴƎ ǊǘƭψƎŘōψŘŜōǳƎΦǘȄǘ ŦƛǊǎǘ όǘƘƛǎ ǇǊƻŎŜǎǎ ƛǎ ǎƛƳƛƭŀǊ ǘƻ the process 

of KM0). Then, set the bit[25] of memory address 0x4800_03f8 to 1 because the boot process of KM4 is controlled by the KM0. Without 
this operation, the KM4 can't jump out of the boot function. Details of this operation are as follows: After executinƎ άƳŀƪŜ ŘŜōǳƎέ 
instruction, a debug window pops up. In this window. Set bit[нрϐ ǘƻ мΣ ǘƘŜƴ ǘȅǇŜ άŎέΣ ǘƘŜ Yaп ƛǎ ǊŜǎŜǘΦ ǊŜŦŜǊ ǘƻ Fig 1-32 for more 
information. 

 
Note: Only resetting KM0 may cause KM4 to work in an abnormal way because KM0 reboot will change some settings of KM4. If you find KM4 
ŘƻŜǎƴΩǘ ǿƻǊƪ ŀŦǘŜǊ Yaл reboot, you should reset KM4. 
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Fig 1-32 KM4 άmonitor resetέ setting 
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2 SDK Architecture 

The architecture of SDK is shown in Fig 1-1. 
 

 

Fig 2-1 SDK architecture 

2.1 component 

2.1.1 common 

Items Description 

api  ̧ AT command 
 ̧ Platform_stdlib.h: standard library header 
 ̧ Wi-Fi driver interface 
 ̧ Wi-Fi promisc mode interface 
 ̧ Wi-Fi simple configuration 

application  ̧ DuerOS 
 ̧ MQTT 

audio Audio related 

bluetooth Internal BT driver 

drivers  ̧ alc5616/  alc5640/  alc5651/  alc5660/  alc5679/  alc5680/  sgtl5000 drivers 
 ̧ IR NEC driver 
 ̧ SDIO host driver 
 ̧ Ameba-D internal codec rl6548 driver 
 ̧ USB host and device drivers 
 ̧ WLAN driver 

example Utility examples: wlan_fast_connect/ssl_download/  fatfs/mdns/media_geo_mp4 Χ 

file_system File system 

grahpic JPEG decoder 

mbed mbed API source code 

media Multi-media framework 

network  ̧ coap 
 ̧ dhcp 
 ̧ http 
 ̧ lwip 
 ̧ mDNS 
 ̧ rtsp 
 ̧ sntp 
 ̧ ssl (MBEDTLS) 
 ̧ tftp  
 ̧ websocket 

test  ̧ WLAN test file 

ui  ̧ emWin 
 ̧ littlevGL 

utilities  ̧ cJSON 
 ̧ http_client 
 ̧ ssl_client 
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 ̧ tcpecho 
 ̧ udpecho 
 ̧ webserver/xml 

video Video related 

2.1.2 os 

Items Description 

freertos FreeRTOS source code 

os_dep  ̧ osdep_service.c: Realtek encapsulating interface for FreeRTOS 
 ̧ osdep_service.h: Realtek encapsulating interface header 

2.1.3 soc 

Items Description 

app monitor and shell 

bootloader Bootloader 

cmsis ARM headers, include ARM CPU registers and operations 

cmsis-dsp ARM CMSIS-DSP source code 

fwlib Low level drivers like: UART/I2C/SPI/Timer/PWM Χ 

fwlib/usrcfg User configuration files, maintained by user: bootcfg/trustzonecfg/sleepcfg/flashcfg/pinmapcfg Χ 

img3 Files for image3 

imgtool_floader Flash loader for image tool 

misc misc ŦƛƭŜ ƭƛƪŜ ƻǘŀκǇƳǳΧ 

swlib Standard software library supported by ROM code, like: _memcpy/_memcmp Χ 

2.2 doc 

Items Description 

AN0004 Realtek low power Wi-Fi MP user guide 

AN0011 Realtek WLAN simple configuration 

AN0012 Realtek secure socket layer (SSL) 

AN0025 Realtek AT command 

AN0075 Realtek Ameba-all at command v2.0 

AN0096 Realtek Ameba-all xmodem uart update firmware 

UM0150 Realtek Ameba CoAP User Guide.pdf 

2.3 tools 

Items Description 

ImageTool tools\AmebaD\Image_Tool: image tool for Ameba-D 

autopatch Automatically patched script 

bluetooth Tools for BT 

DownloadServer Used to send image to device based on socket by OTA function. 

DownloadServer(HTTP) Used to send image to device based on socket by OTA function. 

file_check_sum File used to check sum for Flash 

probe Tools for RLX Probe debug 

serial_to_usb Driver for serial to usb 

simple_config_wizard Tools for Wi-Fi simple configuration 

simple_config_wizard_3.4b Tools for Wi-Fi simple configuration 

iperf.exe iperf for Wi-Fi performance test 
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2.4 GCC Project for KM4 

The architecture of KM4 project is shown in Fig 2-2. 
 

 

Fig 2-2 Architecture of KM4 
 

Items Description 

asdk  ̧ Menuconfig 
 ̧ Link script 
 ̧ Library: lib_wlan.a/lib_wps.a/rom_symbol Χ 
 ̧ Makefile 

example_sources Peripherals driver demo code: ADC/Audio/LCD/UART/I2C Χ 

jlink_script J-Link script for KM4 

toolchain GCC & Cygwin toolchain 

Makefile Top Makefile 

2.5 Critical Header Files 

Items Description 

basic_types.h SUCCESS/FAIL/TRUE/FALSE/NULL/u8/u16/u32/BOOLκ.L¢όȄύ Χ 

platform_stdlib.h Standard library API: memcmp/strcpy/atoll/strpbrk/sscanf/printf/sprint/snprintf/vsnprintf Χ 

section_config.h Section definition used in link script: IMAGE2_RAM_TEXT_SECTION Χ 

mbed api headers component/common/mbed/ Χ 
 ̧ Peripheral header files for mbed APIs 
 ̧ If you want to use mbed APIs, related headers must be included. 

ameba_soc.h  ̧ Peripheral header files for raw APIs 
 ̧ Raw APIs have more features that mbed APIs, mbed APIs just have basic features. 
 ̧ If you want to use raw APIs, this header must be included. 
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3 GCC Makefile 

3.1 KM4 Makefile Architecture 

The architecture of KM4 makefile is shown in Fig 3-1. 
 

project_hp\Makefile-->

project_hp\asdk\Makefile-->

project_hp\asdk\make\Makefile-->

project_hp\asdk\make\api\Makefile

project_hp\asdk\make\app\Makefile

project_hp\asdk\make\application\Makefile

project_hp\asdk\make\audio\Makefile

project_hp\asdk\make\bootloader\Makefile

project_hp\asdk\make\cmsis\Makefile

project_hp\asdk\make\drivers\Makefile

project_hp\asdk\make\example\Makefile

project_hp\asdk\make\file_system\Makefile

project_hp\asdk\make\mbed\Makefile

project_hp\asdk\make\mbedtls\Makefile

project_hp\asdk\make\network\Makefile

project_hp\asdk\make\os\Makefile

project_hp\asdk\make\rtl_bluetooth\Makefile

project_hp\asdk\make\ssl\Makefile

project_hp\asdk\make\tartget\Makefile

project_hp\asdk\make\utilities\Makefile

project_hp\asdk\make\utilities_example\Makefile

project_hp\asdk\make\wlan\Makefile

project_hp\asdk\make\wps\Makefile

project_hp\asdk\make\utilities_example\Makefile

project_hp\ asdk\ make\ preject\ MakefileĄ 

project_hp\ asdk\ make\project\ sram\ Makefile: how to build code into ram

project_hp\ asdk\ make\project\ xip\ Makefile: how to build code into flash

project_hp\ asdk\ make\project\ library\Makefile: how to build library

 

Fig 3-1 KM4 Makefile architecture 

3.2 How to Build Code into Flash? 

Makefile in project/xip is an example for how to build code into Flash. 
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3.3 How to Build Code into SRAM? 

Makefile in project/SRAM is an example for how to build code into SRAM. 
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3.4 How to Use Section Attribute? 

Because SRAM space is limited, we suggest you build critical code/data into SRAM and let other code/data left in Flash. You should use section 
ŀǘǘǊƛōǳǘŜ άIMAGE2_RAM_TEXT_SECTIONέ ǘƻ ƭƻŎŀǘŜ ǎƻƳŜ ƻŦ ȅƻǳǊ ŦǳƴŎǘƛƻƴǎ ƛƴǘƻ {w!aΦ  
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Note: 

 ̧ You ǎƘƻǳƭŘ ƛƴŎƭǳŘŜ άǎŜŎǘƛƻƴψŎƻƴŦƛƎΦƘέ 
 ̧ const/read-only data will build into Flash 
 ̧ Non read-only data will build into Sw!a όLŦ ȅƻǳ ƴŜŜŘ ǊŜŀŘ ƻƴƭȅ Řŀǘŀ ōǳƛƭŘ ƛƴǘƻ {w!a ǘƻ Ǌǳƴ ŦŀǎǘŜǊΣ ȅƻǳ ǎƘƻǳƭŘ ƴƻǘ ǳǎŜ άŎƻƴǎǘέύ 
 ̧ Functions limited by IMAGE2_RAM_TEXT_SECTION will build into SRAM 
 ̧ Functions not limited by IMAGE2_RAM_TEXT_SECTION will build into Flash 

3.5 How to Build Library? 

Makefile in project/library is an example for build user library. 
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3.6 How to Add Library? 

Open project_hp\ asdk\ Makefile, and add lib_user.a into LINK_APP_LIB. 

LINK_APP_LIB += $(ROOTDIR)/lib/application/ lib_user.a  
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4 C++ Standards Supported in GCC 

4.1 Introduction 

This chapter mainly introduces how to build C++ codes in Ameba-D GCC project.  
 
Note: άiostreamέ is not available currently. 

4.2 To Compile C++ Codes 

The following steps are necessary to support C++ in current GCC project. 
 
(1) Modify the link script: rlx8721d_img2_is.ld (non-security) or rlx8721d_img2_tz.ld (security). 

   
 
(2) Modify startup code: rtl8721dhp_app_start.c. 
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(3) Modify makefile. 

 ̧ project\ realtek_amebaD_va0_example\GCC-RELEASE\project_hp\asdk\Makefile 

 
 

 ̧ project\ realtek_amebaD_va0_example\GCC-RELEASE\project_hp\asdk\Makefile.include.gen 

   

 
(4) Add C++ files into protect.  

We have tested a small program and provide it as an example, which can be found in main.cpp. 
 
(5) Use command make in console to compile project with C++ files. 
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5 GCC Standard Library 

5.1 Introduction 

This chapter mainly introduces how to use GCC standard library in Ameba-D. 
 
To save flash memory and improve efficiency, ROM code has implemented a standard software library, like _memcpy and_memcmp; and some 
functions are simplified version in ROM software library, such as printf and sprintf. 
 
There are two methods when using standard library functions such as printf and sprintf in GCC: 

 ̧ Using ROM software library. 
 ̧ Using GCC standard library. 

5.2 Default Use of Library Function 

In current SDK, the default use of library function is illustrated in Fig 5-1 and Table 5-1 

STD LIB Functions

ROM Software Library GCC Standard Library

ü fprintf
ü puts
ü ...

ü memchr
ü memcmp
ü memcpy
ü memset
ü memmove
ü strcmp
ü strcpy
ü strlen
ü strncmp
ü strncpy
ü strsep
ü strtok

ü strcat
ü strchr
ü strncat
ü strstr
ü atol
ü atoi
ü strpbrk
ü strtoul
ü strtol
ü rand
ü srand

ü printf
ü sscanf
ü sprintf
ü snprintf
ü vsnprintf

LIB CONFIGURABLE

 

Fig 5-1 Library function guide 

Table 5-1 Default use of library function 

Item Function 

Using ROM software library memchr/memcmp/memcpy/memset/memmove/strcmp/strcpy/strlen/strncmp/strncpy/strsep/strtok/strcat
/strchr/strncat/strstr/atoll/atoi/strpbrk/strtoul/strtol/ rand/srand 

Using GCC standard library fprintf/puts/Χ 

Library is configurable printf/ sprintf/snprintf/vsnprintf/ sscanf 
Note: The default library is ROM software library; you can switch to GCC standard library by defining macro 
STD_PRINTF. 

 
Because printf/sprintf/snprintf/vsnprintf/sscanf in ROM software library are a simplified version compared with these in GCC standard library, 
they only support a few formats. In order to remind users that unsupported format occurs when using these functions in ROM library, SDK 
wraps up these functions. 

Table 5-2 Wrapper functions 

Item Wrapper Function 

printf _rtl_printf 



 Ameba-D 

Application Note All information provided in this document is subject to legal disclaimers. © REALTEK 2021. All rights reserved. 

44 

sprintf _rtl_sprintf 

snprintf _rtl_snprintf 

vsnprintf _rtl_vsnprintf 

sscanf _rtl_sscanf 

 
When using printf/sprintf/ snprintf/vsnprintf/sscanf in GCC standard library, the memory size will increase 40KB compared with using these 
functions in ROM software library. 

5.3 To Use Configurable Function in GCC Standard Library 

Compared to printf/sprintf/snprintf/vsnprintf/ sscanf functions in GCC library, they only support a few formats in ROM library. The following 
content takes printf as an example. 

Table 5-3 printf supported format 

Library printf Supported Format 

ROM software library %s, %x, %X, %p, %P, %d, %c 

GCC standard library %s, %x, %X, %p, %P, %d, %c, %f, %L, %l, %u, %U, %e, %E, Χ 

 
For printf/ sprint/snprintf/vsnprintf/sscanf, ROM library is linked by default. If άformat not support!έ log dumps out in trace tool, it means that 
unsupported format occurs, you should link these functions to GCC standard library. 
 
To use printf/ sprint/snprintf/vsnprintf/sscanf in GCC standard library, follow these steps: 
(1) Add #define STD_PRINTF in the front. 
There are two cases: 

Item Operation Description 

case 1 Add #define STD_PRINTF in the front of c files, and include άplatform_stdlib.hέ Change printf/sprint/snprintf/vsnprintf/sscanf 
of some filesΩ link to GCC standard library. 
Example: 

 
case 2 Add #define STD_PRINTF in the front of άplatform_stdlib_rtl8721d.hέ Change printf/sprint/snprintf/vsnprintf/sscanf 

of all SDKΩǎ link to GCC standard library. 

 
(2) Modify άplatform_stdlib_rtl8721d.hέ file if you donΩt want to switch to use all the five functions in GCC standard library. 

In SDK, macro STD_PRINTF controls printf/ sprintf/snprintf/vsnprintf/sscanf at the same time. If you only want to configure some but not 
all, for example, you only want to use printf in GCC standard library, and other four functions sprintf/snprintf/vsnprintf/sscanf maintain 
the default state, you need to modify άplatform_stdlib_rtl8721d.hέ file. 
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5.4 Tips 

 ̧ If you wants to use GCC standard library, we recommend only link some user specified c files to GCC standard library instead of link all 
SDK to GCC standard library, because printf/sprint/snprintf/vsnprintf/sscanf in our SDK should link to ROM standard library. 

 ̧ If using printf in GCC standard library libc.a, and there is no "\n" in the end, use fflush(stdout) after printf to dump log in cache. For 
example: 

printf("hello"); 
fflush(stdout); 

 ̧ In current GCC project, KM0 does not support floating-point temporarily, so printf cannot dump %f in KM0 in default setting. 
 ̧ If using sscanf in GCC standard library libc.a, delete _strtol_r and _strtoul_r symbols in rlx8721d_rom_symbol_acut.ld. 
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6 IAR Build Environment Setup 

This chapter illustrates how to setup IAR development environment for Realtek Ameba-D SDK, including building projects, downloading images 
and debugging. 

6.1 Requirement 

6.1.1 IAR Embedded Workbench 

L!w ǇǊƻǾƛŘŜǎ ŀƴ L59 ŜƴǾƛǊƻƴƳŜƴǘ ŦƻǊ ŎƻŘŜ ōǳƛƭŘƛƴƎΣ ŘƻǿƴƭƻŀŘƛƴƎΣ ŀƴŘ ŘŜōǳƎƎƛƴƎΦ /ƘŜŎƪ άL!w 9ƳōŜŘŘŜŘ ²ƻǊƪōŜƴŎƘέ ƻƴ http://www.iar.com/, 
and a trail version is available for 30 days.  
 
Note: To support ARMv8-M with Security Extension (Ameba-D HS CPU, also called KM4), IAR version must be 8.30 or higher. 

6.1.2 J-Link or RLX Probe 

If you need to download images or debug code for Ameba-D with IAR, then a J-Link adapter or a RLX Probe is necessary.  
 
Note: For Ameba-D CPU, the J-Link version must be v9 or higher. 

6.2 Hardware Configuration 

The hardware block diagram of Ameba-D demo board is shown in Fig 6-1. 
 ̧ USB TO UART: supply power and print logs, baud rate is 115200 bps. 
 ̧ SWD: SWD interface, used for image downloading and debugging with IAR. 
 ̧ Reset button: reset Ameba-D to run firmware after IAR completes downloading. 

http://www.iar.com/
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Fig 6-1 Ameba-D demo board 

6.2.1 Connecting with J-Link 

Refer to Fig 6-2 and Fig 6-3 to connect Ameba-D SWD interface with J-Link. 
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Fig 6-2 J-Link and SWD connection diagram 
 

 

Fig 6-3 J-Link and Ameba-D SWD connection 

6.2.2 Connecting with RLX Probe 

Refer to Fig 6-4 and Fig 6-5 to connect Ameba-D SWD interface with RLX Probe. 
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Fig 6-4 RLX Probe and SWD connection diagram 

 

Fig 6-5 RLX Probe and Ameba-D SWD connection 

6.3 How to Use IAR SDK? 

6.3.1 IAR Project Introduction 

Because Ameba-D is a dual-core CPU platform, two workspaces are provided to build for each core in 
project\ realtek_amebaD_va0_example\ EWARM-RELEASE. 

 ̧ Project_lp_release.eww (KM0 workspace) contains the following projects: 
Â km0_bootloader 
Â km0_application 

 ̧ Project_hp_release.eww (KM4 workspace) contains the following projects: 
Â km4_bootloader 
Â km4_application 
Â km4_secure 

 
Each project in KM4 workspace has different build configurations, as Table 6-1 shows. 
 



 Ameba-D 

Application Note All information provided in this document is subject to legal disclaimers. © REALTEK 2021. All rights reserved. 

50 

Table 6-1 Build configurations for KM4 project 

Project Build Configuration Configure TrustZone Enable MP 

km4_bootloader km4_bootloader - is1 N N 

km4_bootloader - tz2 Y N 

km4_application km4_application - is N N 

km4_application - tz Y N 

km4_application - is (mp3) N Y 

km4_application - tz (mp) Y Y 

km4_secure km4_secure - tz Y N 

km4_secure - tz (mp) Y Y 

Note: 
1. The configuration ƛǘŜƳǎ ǿƛǘƘ ά-ƛǎέ ŀǊŜ ƛƎƴƻǊŜ ǎŜŎǳǊŜ ŎƻƴŦƛƎǳǊŀǘƛƻƴΣ ǿƘƛŎƘ ŀǊŜ ŘŜǎƛƎƴŜŘ ŦƻǊ ŀǇǇƭƛŎŀǘƛƻƴǎ ǘƘŀǘ Řƻ ƴƻǘ ǳǎŜ ¢Ǌǳǎǘ½ƻƴŜΦ 
2. The ŎƻƴŦƛƎǳǊŀǘƛƻƴ ƛǘŜƳǎ ǿƛǘƘ ά-ǘȊέ ŀǊŜ ¢Ǌǳǎǘ½ƻƴŜ ŎƻƴŦƛƎǳǊŀǘƛƻƴΣ ǿƘƛŎƘ ŀǊŜ ŘŜǎƛƎƴŜŘ ŦƻǊ ŀǇǇƭƛŎŀǘƛƻƴǎ ǘƘŀǘ ǳǎŜ ¢Ǌǳǎǘ½ƻƴŜΦ 
3. The configuration items ǿƛǘƘ άƳǇέ ŀǊŜ Ƴŀǎǎ ǇǊƻŘǳŎǘƛƻƴ ŎƻƴŦƛƎǳǊŀǘƛƻƴΣ ǿƘƛŎƘ ŀǊŜ ŘŜǎƛƎƴŜŘ ŦƻǊ ƎŜƴŜǊŀǘƛƴƎ at ƛƳŀƎŜΦ 
 

 ̧ For applications that do not use TrustZone, users should apply ignore secure configurations as Table 6-2 shows. The km4_secure project 
which contains Trustzone-protected code, is not used. 

 ̧ For applications that use TrustZone, users should apply TrustZone configurations as Table 6-2 shows. 

Table 6-2 Configurations for project with/without TrustZone 

Project TrustZone Normal Image MP Image 

km4_bootloader N km4_bootloader - is km4_bootloader - is 

Y km4_bootloader - tz km4_bootloader - tz 

km4_application N km4_application - is km4_application - is (mp) 

Y km4_application - tz km4_application - tz (mp) 

km4_secure Y km4_secure - tz km4_secure - tz (mp) 

 
At the top of the Workspace window, there is a drop-down list where you can choose a build configuration for a specific project. 
 

Configuration 
drop-down menu Ƙ 

ƙ ƚ 

 

Fig 6-6 How to choose a build configuration 

6.3.2 IAR Build 

When building SDK for the first time, you should build both KM0 project and KM4 project. Other times, you only need to rebuild the modified 
project. 

6.3.2.1 Building KM0 Project 

The following steps show how to build KM0 project: 
(1) Open project\ realtek_amebaD_va0_example\ EWARM-RELEASE\ Project_lp_release.eww. 
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(2) Make sure km0_bootloader and km0_application are in Workspace. Click Project > Options, General Options > Target > Processor 
Variant > Core, verify the CPU configurations according to Fig 6-7. 

 

 
 
Note: If you have installed IAR version 9.xx or above from official website, click Tools > Option > Project, and make ensure the setting 

άaŀƪŜ ōŜŦƻǊŜ ŘŜōǳƎƎƛƴƎέ ƛǎ ǎŜǘ ǘƻ άbŜǾŜǊέ ōŜŦƻǊŜ ŜȄŜŎǳǘƛƴƎ ǎǘŜǇ (3) ! ⌠ Ȃ. 

 

Fig 6-7 KM0 processor options 
 
(3) wƛƎƘǘ ŎƭƛŎƪ ǘƘŜ ǇǊƻƧŜŎǘ ŀƴŘ ŎƘƻƻǎŜ άwŜōǳƛƭŘ !ƭƭέΣ ŀǎ Fig 6-8 shows. The km0_bootloader and km0_application should compile in order. 
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Fig 6-8 Building KM0 project 
 
Note: After building each project, IAR will pop up a command prompt window to execute post-build action to generate images from executable 
ŦƛƭŜǎΦ ¢Ƙƛǎ Ƴŀȅ ǘŀƪŜǎ ǎŜǾŜǊŀƭ ǎŜŎƻƴŘǎΦ 5ƻƴΩǘ ǎǘƻǇ ƛǘ ǿƘƛƭŜ ƛǘ ƛǎ ƛƴ ǇǊƻƎǊŜǎǎΦ !ŦǘŜǊ Ǉƻǎǘ-build action is completed, the window would disappear 
automatically. 
 

 
 
(4) After compile, the images km0_boot_all.bin and km0_image2_all.bin can be seen in project\ realtek_amebaD_va0_example\ EWARM-

RELEASE\ Debug\ Exe\ km0_image. 

6.3.2.2 Building KM4 Project 

The following steps show how to build KM4 project: 
(1) Open project\ realtek_amebaD_va0_example\EWARM-RELEASE\Project_hp_release.eww. 
(2) Refer to 6.3.1 and choose the build configurations for each project according to your application. 
(3) Click Project > Options, General Options > Target > Processor Variant > Core, verify the CPU configurations according to Fig 6-9. 
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Fig 6-9 KM4 processor options 
 

Note: If you have installed IAR version 9.xx or above from official website, click Tools > Option > Project, and make ensure the setting 
άaŀƪŜ ōŜŦƻǊŜ ŘŜōǳƎƎƛƴƎέ ƛǎ ǎŜǘ ǘƻ άbŜǾŜǊέ ōŜŦƻǊŜ ŜȄŜŎǳǘƛƴƎ ǎǘŜǇ (4). 

 
 
(4) wƛƎƘǘ ŎƭƛŎƪ ǘƘŜ ǇǊƻƧŜŎǘ ŀƴŘ ŎƘƻƻǎŜ άwŜōǳƛƭŘ !ƭƭέΣ ŀǎ Fig 6-10 shows. The km4_bootloader, km4_secure and km4_application should 

compile in order. 
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Fig 6-10 Building KM4 project 
 
Note: 

 ̧ When TrustZone is enable, the km4_secure project must be built before the km4_application project. When TrustZone is not used, there 
is no need to compile the km4_secure project. 

 ̧ After building each project, IAR will pop up a command prompt window to execute post-build action to generate images from executable 
ŦƛƭŜǎΦ ¢Ƙƛǎ Ƴŀȅ ǘŀƪŜǎ ǎŜǾŜǊŀƭ ǎŜŎƻƴŘǎΦ 5ƻƴΩǘ ǎǘƻǇ ƛǘ ǿƘƛƭŜ ƛǘ ƛǎ ƛƴ ǇǊƻƎǊŜǎǎΦ !ŦǘŜǊ Ǉƻǎǘ-build action is completed, the window would 
disappear automatically. 

 

 
 
(5) After compile, the images km4_boot_all.bin and km0_km4_image2.bin can be seen in project\ realtek_amebaD_va0_example\ EWARM-

RELEASE\ Debug\ Exe\ km4_image. For MP configurations, the km0_km4_image2_mp.bin would be generated instead. 

6.3.3 IAR Download 

The generated images can be downloaded in two ways: 
 ̧ IAR J-Link or RLX Probe SWD (introduced in the next section) 
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 ̧ Ameba-D ImageTool, refer to ImageTool for more information. 
 
Ameba-D demo board supports using J-Link and RLX Probe SWD to download and debug. Image of each project can be download individually. 
 
Note: Considering KM4 is powered-on by KM0, you should make sure that KM0 has boot up already before downloading images to KM4. 
Otherwise, for J-Link, J-Link ŎŀƴΩǘ ŎƻƴƴŜŎǘ ǘƻ Yaп ŀƴŘ ǎƘƻǿ ǘƘŜ ŜǊǊƻǊ ƳŜǎǎŀƎŜ ŀǎ Fig 6-11 shows. CƻǊ w[· ǇǊƻōŜΣ w[· tǊƻōŜ ŘǊƛǾŜǊ ŎŀƴΩǘ ōŜ 
opened under KM4. 
 

 

Fig 6-11 J-Link cannot find KM4 
 
As a result, if the Flash memory is empty, the sequence to download images is: 
(1) Download for km0_bootloader and km0_application projects 
(2) Click Reset button on demo board to make KM0 boots up 
(3) Download for km4_bootloader and km4_application projects 
 
During development, if Flash memory is not empty and KM0 can boot up successfully, then you can download updated images to KM4 directly, 
and there is no need to re-download for KM0. 
 
The following steps show how to download image for the target project with IAR. If there is an error like Fig 6-24 displayed in IAR window, refer 
to 6.3.4.3. 
(1) Choose the target project display in Workspace window, for example, km4_bootloader as Fig 6-12 shows. 
(2) If using J-link debugger, check whether the J-link debugger setting is correct. 

a) Click Project > Options > Debugger > Setup > DriverΣ ŀƴŘ ŎƘƻƻǎŜ άW-Link/J-¢ǊŀŎŜέΣ ŀǎ Fig 6-13 shows. 
b) Click Debugger > J-Link/J-Trace > Connection > InterfaceΣ ŀƴŘ ŎƘƻƻǎŜ ά{²5έΣ ŀǎ Fig 6-14 shows. 
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Fig 6-12 Switching to the target project view 
 

 

Fig 6-13 J-Link debugger setup 
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Fig 6-14 J-Link interface setup 
 
(3) If using RLX Probe, check whether the RLX Probe setting is correct. 

a) Click Project > Options > Debugger > Setup > DriverΣ ŎƘƻƻǎŜ άD5. {ŜǊǾŜǊέ ŀƴŘ don not ŎƘƻƻǎŜ άwǳƴ ǘƻέΣ ŀǎ Fig 6-15 shows. 
b) Click GDB Server > GDB Server, and Ǉǳǘ ŎƻǊǊŜŎǘ ǾŀƭǳŜ ƛƴ ά¢/tκLt ŀŘŘǊŜǎǎ ƻǊ ƘƻǎǘƴŀƳŜέΣ ŀǎ Fig 6-16 shows. The value should be: 

localhost, port number. 
É KM4: The default port numbers is 3333, which is set in project\ realtek_amebaD_va0_example\ EWARM-

RELEASE\ probe\ cm4\ rlx_probe0.cfg. 
É KM0: The default port numbers is 2331, which is set in project\ realtek_amebaD_va0_example\ EWARM-

RELEASE\ probe\ cm0\ rlx_probe0.cfg. 
c) Open RLX Probe in project\ realtek_amebaD_va0_example\ EWARM-RELEASE\ probe\ cm4\ cm4_RTL_Probe, as Fig 6-17 shows. 
Note: The board must be reset before opening the RLX Probe, otherwise the connection may fail. 

 

 

Fig 6-15 RLX Probe setup 
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Fig 6-16 RLX Probe interface setup 
 

 

Fig 6-17 RLX Probe window 
 
(4) Click Project > Download > Download active application, image downloading starts. 

When downloading, Ameba-D prints the log, as Fig 6-18 shows. You can check the log to see if download is successful. 
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Fig 6-18 Downloading log 
 
(5) You can also erase all parts of the Flash memory if necessary. 
 

 

Fig 6-19 Erasing Flash memory 

6.3.4 IAR Debug 

You can debug or trace KM0 and KM4 system individually with J-Link or RLX Probe SWD. 
 
Note: Considering KM4 is power-on by KM0, you should make sure that KM0 has already boot up before debug KM4. For KM0, there is no such 
requirement because KM0 is power-on immediately after reset. 
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6.3.4.1 J-Link Debug 

Follow the steps to debug and trace code of target project with IAR by J-Link: 
(1) Set the target project as active project and verify the debugger configurations as step (1) and (2). 
(2) Click Project > Download and Debug or Project > Debug without Downloading. 

Â Download and Debug: downloads the application and debug the project object file. If necessary, a make will be performed before 
download to ensure the project is up to date.  

Â Debug without Downloading: debug the project object file 
(3) When starting IAR C-SPY to debug, it will firstly reset the target CPU and run to the main function, as Fig 6-20 shows. 
(4) Toggles a breakpoint at the statement or instruction that contains or is located near the cursor in the source window. ¢ƘŜ ά¢ƻƎƎƭŜ 

.ǊŜŀƪǇƻƛƴǘέ button is on the debug toolbar, as Fig 6-21 shows. 
 

 

Fig 6-20 Running to main() when debug 
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Fig 6-21 Toggle breakpoint 
 
(5) You can trace ŎƻŘŜ ǎǘŜǇ ōȅ ǎǘŜǇ ǿƛǘƘ ά{ǘŜǇ Lƴǘƻέ ƻǊ άDƻέ ǳƴǘƛƭ ǘǊƛƎƎŜǊƛƴƎ ŀ ōǊŜŀƪǇƻƛƴǘΦ ¢ƘŜǎŜ ŦǳƴŎǘƛƻƴ ōǳǘǘƻƴǎ ŀǊŜ ŀǾŀƛƭŀōƭŜ ƻƴ ǘƻƻƭōŀǊΦ 
 
Note: If you want to trace the code step by step in km4_bootloader, click Options > C/C++ Compiler > Output > Generate under 
km4_boƻǘƭƻŀŘŜǊΣ ŀƴŘ ŎƘŜŎƪ ǘƘŜ ǎŜǘǘƛƴƎ άDŜƴŜǊŀǘŜ ŘŜōǳƎ ƛƴŦƻǊƳŀǘƛƻƴέΦ 

 

6.3.4.2 RLX Probe Debug 

Follow the steps to debug and trace code of target project with IAR by RLX Probe: 
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(1) Set the target project as active project and verify the debugger configurations as step (1) and step (3). 
(2) Click Project > Attach to Running Target. 
(3) Set the target address. 

When starting debug with RLX Probe, it will firstly reset the target CPU. If you want to run to a target address at first, you can set the PC 
address in project\ realtek_amebaD_va0_example\ EWARM-RELEASE\ probe\ cm4\ rlx_probe0.cfg. The method is that uncomment 
άŜǿ ΦǇŎ Ґ лȄȄȄȄȄȄȄȄȄέ ŀƴŘ ŎƘŀƴƎŜ ǘƘŜ ŀŘŘǊŜǎǎ ǘƻ ǘƘŜ ŀǇǇƻƛƴǘŜŘ ǾŀƭǳŜΣ ŀǎ Fig 6-22 and Fig 6-23 shows. 

 

 

Fig 6-22 Setting the target address 
 

 

Fig 6-23 Running to the target address when debug 
 
(4) Toggles a breakpoint at the statement or instruction that contains or is located near the cursor in the source window. ¢ƘŜ ά¢ƻƎƎƭŜ 

.ǊŜŀƪǇƻƛƴǘέ button is on the debug toolbar, as Fig 6-21 shows. 
(5) You Ŏŀƴ ǘǊŀŎŜ ŎƻŘŜ ǎǘŜǇ ōȅ ǎǘŜǇ ǿƛǘƘ ά{ǘŜǇ Lƴǘƻέ, ƻǊ άDƻέ ǳƴǘƛƭ ǘǊƛƎƎŜǊƛƴƎ ŀ ōǊŜŀƪǇƻƛƴǘΦ ¢ƘŜǎŜ ŦǳƴŎǘƛƻƴ ōǳǘǘƻƴǎ ŀǊŜ ŀǾŀƛƭŀōƭŜ ƻƴ ǘƻƻƭōŀǊ. 

6.3.4.3 IAR Debug or Download Error 

Because Ameba-D has two CPU cores, and a post-build script will be run after make, sometimes the debug or download thread cannot get the 
correct AXF file for debug or download, the error like Fig 6-24 happens. 
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Fig 6-24 IAR debug or download error 
 
To avoid this error, you should build manually before debug or download, and disable auto-build from Tools > Options > Project > Make before 
debugging, as Fig 6-25 shows. 




































































































































































































































































































































































































































